SPIDER: upgrade failure

book

Article ID: 193444

calendar_today

Updated On:

Products

CA Application Performance Management Agent (APM / Wily / Introscope) CA Application Performance Management (APM / Wily / Introscope) INTROSCOPE DX Application Performance Management

Issue/Introduction


We tried to upgrade from 10.7.0.109 (Build 991300) to 10.7.0.212.  When starting the Liberty instance, the agent did not start.  No logs, no errors in system out.  Nothing! 

The older agent was "improperly" running with Agent.jar rather than the NoRedef version.   

Looking at the running process (ps -ef) it shows all parameters in the command line.

jvm.options

#-javaagent:/IntroscopeAgent/wily/Agent.jar
-javaagent:/IntroscopeAgent/wily/AgentNoRedefNoRetrans.jar
#-Dcom.wily.introscope.agentProfile=/IntroscopeAgent/wily/core/config/IntroscopeAgent.websphere.profile
-Dcom.wily.introscope.agentProfile=/IntroscopeAgent/wily/core/config/IntroscopeAgent.websphere.NoRedef.profile
-Dorg.osgi.framework.bootdelegation=com.wily.*
-Dcom.wily.introscope.agent.agentName=SPIDER_UMM_242


Liberty Version:

 $ ./productInfo version
Product name: WebSphere Application Server
Product version: 19.0.0.1
Product edition: ND


JRE version:

[[email protected]][/usr/WebSphere85/wlp/java/8.0/bin/]# ./java -version
java version "1.8.0_201"
Java(TM) SE Runtime Environment (build 8.0.5.30 - pap6480sr5fp30-20190207_01(SR5 FP30))
IBM J9 VM (build 2.9, JRE 1.8.0 AIX ppc64-64-Bit Compressed References 20190124_408237 (JIT enabled, AOT enabled)
OpenJ9   - 9c77d86
OMR      - dad8ba7
IBM      - e2996d1)
JCL - 20190207_01 based on Oracle jdk8u201-b09

Please advise.

Cause

Using unsupported compatibility.

Environment

Release : 10.7.0

Component : APM Agents

Resolution

WebSphere Liberty 19 is not supported for APM 10.7. It should not have been working at all! It is supported in APM 11.x onward (SAAS). This can work pointing to a 10.7 EM AGent with the approval of Product Manager to use this combination.