Number of Active Workers shown in Enterprise Manager ApplicaitonTriageMap

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Article ID: 193388

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Updated On:

Products

CA Application Performance Management Agent (APM / Wily / Introscope) CA Application Performance Management (APM / Wily / Introscope) INTROSCOPE DX Application Performance Management

Issue/Introduction

We are reviewing 20 minute graph of the Enterprise Manager ApplicationTriageMap active workers metric.

Metric Path: Enterprise Manager|ApplicationTriageMap:Number of Active Workers

In this 20 minute period we see the active workers reaching the maximum value of 20 three times.Sometimes we see the max being reached even more often. 

1. What does it mean when the active workers reach the max (e.g., what is the impact on the system)? 

2. Can the maximum be raised? 

3. Should we be concerned that that the Max is reached so often on our system?

Cause

In this environment, we found very high number of transaction traces, APM Team Center data and APM Team Center alert which seems to be the cause of this issue.

Environment

CA Application Performance Management 10.7

Resolution

This metric indicates how many threads are currently used from common thread pool of APM Team Center. It can point to overloading issues.

We suggest to set the following values in IntroscopeEnterpriseManager.properties.

introscope.apm.data.preserving.time=10 DAYS
introscope.apm.alert.preserving.time=5 DAYS
introscope.apm.data.obsolete.time=9 DAYS

Set transaction traces DB value to 3 days.

introscope.enterprisemanager.transactionevents.storage.max.data.age=3

We should further lower the transaction traces sampling value.

Enable the following in IntroscopeEnterpriseManager.properties

introscope.agent.transactiontracer.sampling.perinterval.count=1
introscope.agent.transactiontracer.sampling.interval.seconds=300