What are saf_epiPoz files, how can I remove them?
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What are saf_epiPoz files, how can I remove them?

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Article ID: 19323

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Updated On:

Products

CA Directory CA IT Asset Manager CA Software Asset Manager (CA SAM) ASSET PORTFOLIO MGMT- SERVER CA Service Management - Service Desk Manager CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation AE - Scheduler (AutoSys) Workload Automation Agent CA Process Automation Base CA Service Operations Insight (SOI)

Issue/Introduction

There are files located within:

*:\Program Files\CA\SC\iTechnology

Idx_libepiPoz.nnn and saf_libepiPoz.nnn

And they are filling up the harddrive over a few weeks.

What is the purpose of these files and how can we eliminate them?

Environment

Release: Embedded Entitlements Manager 8.4

Cause

These files are part of a deprecated internal process for EEM that logs events.

These events were originally stored in a flat database file on the EEM host.

This functionality was discontinued in 8.4 and these files no longer serve any purpose.

These files will build up when there was an EEM processing error.

The saf_epi files WILL grow steadily but normally do not exceed 8Mb in size - also there should only be 1 set of files(the idx_ and saf_) which will be actively processed.

However, since there is no longer any process to consume and destroy these files, they can build up over time.

Resolution

Work-around for EEM 8.4:

You can delete these files to clear disk space:

On Windows:

Go to the EEM Server with the files:

Stop the iGateway Service

(go to Start run, type services.msc, find the iGateway server and right click and stop the service)

Open up windows explorer

Go to %IGW_LOC% home directory, and remove the lowest "saf_epiPoz.xxx" file with the corresponding "idx_epiPoz.xxx" file.

Restart the iGateway Service, and monitor the disk usage to avoid space issues.

 

On Linux:

$IGW_LOC$./S99gateway stop/

cd $IGW_LOC$

remove the lowest "saf_epiPoz.xxx" files with the corresponding "idx_epiPoz.xxx" file. Keep the most recent one.

Restart the iGateway Service

$IGW_LOC$./S99gateway start

Additional Information

The only long term solution is to upgrade to EEM 12.6.0.5 or higher.

Current GA version is 12.6.3

EEM 12.6.3 is supported with SOI 4.02 CU3, which is a mandatory patch for SOI.