CSM's Software Catalog Update process fails
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CSM's Software Catalog Update process fails

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Article ID: 193220

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Updated On:

Products

Mainframe Software Manager (Chorus Software Manager) CHORUS SOFTWARE MANAGER

Issue/Introduction

Using CSM to perform the action to 'Update Immediately" the CA RS settings under the Software Catalog in System Settings fails with the error message:

'Error moving CA RS file /u/users/msmserv/mpm/tmproot/MSM.2869048090371688870.scratchpad/CAR2005.TXT to USS database.'

Environment

Release : 6.0

Component : MSM PRODUCT ACQUISITION SERVICE

Cause

Volume space problem.

Resolution

The problem was due to not having enough space on the volume associated with the temp directory:

(Caused by: java.io.IOException: EDC5133I No space left on device.)

In CSM's 'highlevel.SAMPLIB(MSMLIB)' member add the following statements and then cycle the CSMTC task.  


IJO="$IJO -DCSM_MPM.TEMPSPACE.PRIMARY.TRACKS=6000"
IJO="$IJO -DCSM_MPM.TEMPSPACE.SECONDARY.TRACKS=6000"

Note:

Make certain the value (if previously stated) does not exceed 10000 for each of the two statements.
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