Clarity :Advance Report Schedules not shows
search cancel

Clarity :Advance Report Schedules not shows

book

Article ID: 193004

calendar_today

Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

Steps to Reproduce

  1. Login to Clarity using user admin 
  2. Grant the user all Advance Reporting Rights 
  3. Run the Job Create Jaspersoft User Job 
  4. Navigate to one of the report and create a re-occurring schedule for one of the report
  5. Once the schedule is created you will see a Watch Icon beside the report name
  6. Navigate to Administration --> Users and Create New user (example Test User) 
  7. Grant only Advanced Reporting - Navigate to new user 
  8. Run the Job Create User Job (example Test User) 
  9. Login using the new user (example Test User) 
  10. Navigate to Advance Reporting and navigate to the report for which re-occurring schedule has been created 

Environment

Release : 15.x with Jaspersoft 

Component : CA PPM JASPERSOFT

Cause

This is how to information 

Resolution

The re-occurring is not visible to the new user (example Test User) as the re-occurring schedule has been created by user admin. If an user has right Advanced Reporting - Administer then that user will be able to see schedule for all the users.