CA Spectrum - Not able to resolve correct hostname
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CA Spectrum - Not able to resolve correct hostname

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Article ID: 192899

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Updated On:

Products

CA Spectrum

Issue/Introduction

Spectrum Not able to resolve correct hostname for the pingable device.

Environment

Release : 10.x

Component : Spectrum Core / SpectroSERVER

Cause

Added another DNS which was from AWS i.e alternate DNS.

 

Resolution


> Verify the nslookup on the Spectrum system. If its giving the hostname then spectrum should display the same value.

> Need to check the DNS changes, as in this case nslookup pulls hostname but spectrum is not able to display the same as user had alternate DNS and spectrum does not know about new or old dns server. All Spectrum is doing is a gethostbyname lookup for the ip address, the operating system responds to the request and Spectrum uses what the OS responds.

> Remove the alternate DNS entry. Then check it should pull correct data.

 

Additional Information

https://knowledge.broadcom.com/external/article?articleId=49145