CA Business Intelligence 7.1.1 startServers.sh scripts captures a wrong port value
search cancel

CA Business Intelligence 7.1.1 startServers.sh scripts captures a wrong port value

book

Article ID: 192827

calendar_today

Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

CA Business intelligence upgraded to 7.1.1 from 6.4.3 post which we see that that

startupServer. sh script runs in an infinite loop waiting for tomcat port.


Environment

Release : 3.7

Component : CABI JasperReports Server for CA Performance Management

Cause

Captures the wrong port value

Resolution

We see an error in parsing expression that captures the wrong port value.

Edit the startServers.sh and look for the following lines

grep "Connector " server.xml | awk '{print $0;}' | grep "port" | awk -F"=" 'NR==1{print $3;}' | tr -d "\"" | awk -F" " '{print $1}'

should be

grep "Connector " server.xml | awk '{print $0;}' | grep "port" | awk -F"=" 'NR==1{print $4;}' | tr -d "\"" | awk -F" " '{print $1}'

Additional Information

here is an example error: