The net_connect logs are full of DNS lookup failed on hub3A which is a windows server

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Article ID: 192750

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Products

NIMSOFT PROBES DX Infrastructure Management

Issue/Introduction

I'm seeing a lot of DNS lookup failed on hubXX which is a windows server. When I do an nslookup on the name that failed in the net_connect log, in a command prompt on the server it resolves. Why are the names not being resolved by the probe?

Cause

- Environmental/DNS changes/server decommissioning

Environment

Release : 20.1

Component : UIM NET CONNECT

Resolution

In the Prod environment, some servers are resolved via Windows DNS and others are resolved via BIND (Linux, AIX, Solaris, etc.) The number of failures in the net_connect log and therefore traffic generated due to net_connect retrying the ping to the server were caused by various factors.

- Failed lookups due to server decommissioning (server no longer exists, and should be removed from monitoring)
- Failed lookups due to change in server domain, e.g., xxxxnez1 (Windows servers), to xxxxnez2 (UNIX, Linux, AIX, Solaris machines)
- No ticket(s) opened for DNS changes not being reported immediately to the UIM Administrator by the DNS team

For now customer can change the retries setting in net_connect to 0, to minimize the effect n the server - being hammered by continuous connection attempts due to consecutive failed lookups. When the DNS/environmental issues are resolved, the retries can be reset to 1, 2 or 3 when the changes are reconciled.