Client Tools unable to connect to Remote MS SQL database.
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Client Tools unable to connect to Remote MS SQL database.

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Article ID: 192708

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Identity Suite

Issue/Introduction

After upgrading Governance from 14.1 to version 14.3 we are having issues launching Client Tools and getting it to connect to SQL Server.   

Environment

Release : 14.3, 14.4

Component : GovernanceMinder(Role & Compliance Manager)

Cause

Issue was due to the MS SQL database being remote and not having the MS SQL Client tools installed.   This could also occur in a new installation using a remote MS SQL database if the Microsoft SQL Native Client 2012 are not installed.

Resolution

Install the Microsoft SQL Client server tools as documented in the system requirements:
https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/layer7-identity-and-access-management/identity-governance/14-3/installing/system-requirements.html

 

(Optional)  Microsoft SQL Native Client 2012 — Only required if you reference a remote SQL Server instance.

Additional Information

The same holds true for Oracle databases, if the Oracle database is remote the Oracle Client will need to be installed locally to Governance.