Spectrum OneClick post upgrade tomcat log shows "InstallationHistory is missing for landscape"

book

Article ID: 192703

calendar_today

Updated On:

Products

CA Spectrum CA eHealth

Issue/Introduction

After upgrading Spectrum the OneClick tomcat log file - std.out or catalina.out shows this exception:


InstallationHistory is missing for the landscape: ss_3013
InstallationHistory is missing for the landscape: ss_3014
InstallationHistory is missing for the landscape: ss_3015
InstallationHistory is missing for the landscape: ss_3016
InstallationHistory is missing for the landscape: ss_3017
InstallationHistory is missing for the landscape: ss_3018
InstallationHistory is missing for the landscape: ss_3019
InstallationHistory is missing for the landscape: ss_3020
InstallationHistory is missing for the landscape: ss_3021
InstallationHistory is missing for the landscape: ss_3022
InstallationHistory is missing for the landscape: ss_3023
InstallationHistory is missing for the landscape: ss_1001
InstallationHistory is missing for the landscape: ss_1002

Cause

The OC server was upgraded in the middle of the primaries being upgraded so tomcat cache was off.

Environment

Component : Spectrum Core / SpectroSERVER

Resolution

Cycle the Spectrum OneClick Tomcat process AFTER all primary SpectroSERVERs have been upgraded. This allows the cache to be rebuilt.