SSO redirect failing with "HTTP ERROR 500" and "Failed to bind" messages.
search cancel

SSO redirect failing with "HTTP ERROR 500" and "Failed to bind" messages.

book

Article ID: 192612

calendar_today

Updated On: 02-02-2024

Products

CA Performance Management Network Observability

Issue/Introduction

After NetOps Portal upgrade, it is possible to login to the web UI page, but the redirect to SSO fails with the following error:
....
HTTP ERROR 500
Problem accessing /sso/sign-in-process.jsp. Reason:
Server Error
....

Environment

Component : NetOps Portal

Cause

This can happen if the same port is used by other services, or the previous service instance (caperfcenter_sso service) did not stop properly during the upgrade.

Resolution

Review the sso.log file on NetOps Portal for warning messages like the following:

INFO   | jvm 1    | 2020/06/09 05:17:04 | WARN  | WrapperSimpleAppMain     | 2020-06-09 05:17:04,283 | org.eclipse.jetty.xml.XmlConfiguration                           
INFO   | jvm 1    | 2020/06/09 05:17:04 |       | 
INFO   | jvm 1    | 2020/06/09 05:17:04 | java.security.PrivilegedActionException: java.io.IOException: Failed to bind to 0.0.0.0/0.0.0.0:8381
INFO   | jvm 1    | 2020/06/09 05:17:04 |  at java.security.AccessController.doPrivileged(Native Method)
INFO   | jvm 1    | 2020/06/09 05:17:04 |  at org.eclipse.jetty.xml.XmlConfiguration.main(XmlConfiguration.java:1511)
INFO   | jvm 1    | 2020/06/09 05:17:04 |  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
INFO   | jvm 1    | 2020/06/09 05:17:04 |  at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)

INFO   | jvm 1    | 2020/06/09 05:17:04 | Caused by: java.net.BindException: Address already in use
INFO   | jvm 1    | 2020/06/09 05:17:04 |  at sun.nio.ch.Net.bind0(Native Method)
INFO   | jvm 1    | 2020/06/09 05:17:04 |  at sun.nio.ch.Net.bind(Net.java:433)
INFO   | jvm 1    | 2020/06/09 05:17:04 |  at sun.nio.ch.Net.bind(Net.java:425)
INFO   | jvm 1    | 2020/06/09 05:17:04 |  at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223)
INFO   | jvm 1    | 2020/06/09 05:17:04 |  at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)
INFO   | jvm 1    | 2020/06/09 05:17:04 |  at org.eclipse.jetty.server.ServerConnector.openAcceptChannel(ServerConnector.java:342)
INFO   | jvm 1    | 2020/06/09 05:17:04 |  ... 23 more


The "Failed to bind to..." message seen in the log means the SSO service could not be stopped properly during the upgrade.

Check the status of the running processes with the command "ps -ef" for any old SSO service running before upgrade.

Try shutting down all four NetOps Portal services, then check again with "ps -ef" for any remaining services running.  

If the caperfcenter_sso service could not be stop via the service command, kill it manually with command "kill -9 <processid>", then restart all the NetOps Portal services.

Additional Information

For the appropriate steps to stop and start NetOps Portal services refer to this KB article

https://knowledge.broadcom.com/external/article?articleId=32043