Digital Bank Application showing "Service Unavailable" when doing a Search
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Digital Bank Application showing "Service Unavailable" when doing a Search

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Article ID: 192473

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Updated On:

Products

BlazeMeter

Issue/Introduction

When running the Digital Bank Application on localhost and trying to search for ZIP (eg. 94203), it shows "Service Unavailable":
 
 
 
 
And the application console shows the following Error messages indicating a connection problem with "https://bankingservices.io" URL as it does not recognize the target host:
 
 

Environment

Any

Cause

By default the 3rd party service to obtain data is configured to use bankingservices.io but it needs to be set to use uat-api.synapsefi.com: 

# ===============================
# - ATM Location Service
# - Using Public API Service 
# ===============================
io.demo.bank.atm.protocol=https
io.demo.bank.atm.host=bankingservices.io
io.demo.bank.atm.port=

Resolution

In order to address this issue, please do the following:

1.- Open digitalbank.properties file (located at the Digital Bank home installation, eg: C:\DigitalBankapp)
2.- Update the "ATM Location Service" properties as follows:
# ===============================
# - ATM Location Service
# - Using Public API Service 
# ===============================
io.demo.bank.atm.protocol=https
io.demo.bank.atm.host=uat-api.synapsefi.com
io.demo.bank.atm.port=443

3.- Restart the application from the command line, eg:
java -jar digitalbank-1.0.1.152.jar --spring.config.location=digitalbank.properties --server.port=8081

 

At this point the problem should be resolved and showing the expected results, eg: