"Error in hasPermission() for offering" When trying to log into Service Catalog
search cancel

"Error in hasPermission() for offering" When trying to log into Service Catalog

book

Article ID: 192456

calendar_today

Updated On:

Products

CA Service Management - Service Desk Manager CA Service Catalog

Issue/Introduction

Randomly users cannot log into Catalog. However, the users who are already logged into the application can work normally.

The following error appears in view.log when users are trying to log into Catalog:

ERROR [https-jsse-nio-443-exec-26] [FolderAsset] Error occured Asset.queryObjects(), query: (asset_parent_id = ? and asset_id <> asset_parent_id)
ERROR [https-jsse-nio-443-exec-26] [FolderAsset] Error occured Asset.queryObjects(), query: (asset_parent_id = ? and asset_id <> asset_parent_id)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:81)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:81)
ERROR [https-jsse-nio-443-exec-26] [CRequest] CREQ0015
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:81)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:81)
ERROR [https-jsse-nio-443-exec-12] [OfferingsPermission] Error in hasPermission() for offering: 
ERROR [https-jsse-nio-443-exec-12] [OfferingsPermission] Error in hasPermission() for offering: 

Environment

Release : 17.2

Component : CA SERVICE CATALOG

Cause

EEM configuration problem

Resolution



1) Login EEM UI as EiamAdmin ( Global Application)


2) go to Configure -> User Store -> Group Configuration

set Group Resolution Level as "Resolve direct groups" instead of default "Resolve nested groups"
set Application Resolution Level as " Resolve direct groups" instead of default "Resolve nested groups"

3) Go on EEM server to enable paging on EEM :
In server.xml under ...\CA\SC\EmbeddedEntitlementsManager\config\server\

change : 
<paged>false</paged> 
to : 
<paged>true</paged> 

4) Restart EEM services