Performance Center -> Data Collectors is showing monitored devices but no polled items
search cancel

Performance Center -> Data Collectors is showing monitored devices but no polled items

book

Article ID: 192452

calendar_today

Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

Performance Center -> Data Collectors is showing monitored devices but no polled items

Environment

Release : 3.7

Component : IM Reporting / Admin / Configuration

Cause

Check the following items to validate missing information but the likely culprit is missing files/directories on the Data Aggregator:

Poll configs are created at DA startup, based off poll groups and consolidated monitoring profiles so we check that chain first:

1. DA:8581/rest/pollingconfigs

2. DA:8581/rest/pollgroups

3. DA:8581/rest/consolidatedmonitoringprofiles

4. DA:8581/rest/monitoringprofiles/consolidated/devices

Next check to see if any vendor certs exist within the typecatalog:

1. DA:8581/typecatalog/certifications/snmp/IfXTableMib

If this returns a 404 error check the following folder:

1. /opt/IMDataAggregator/data

Does it contain all 4 folders like this example?

[root@hostname data]# ll
total 0
drwxrwxr-x 3 root root  20 Jul 30  2019 broker
drwxrwxr-x 6 root root 154 Nov 11  2019 certifications
drwxrwxr-x 3 root root  25 Jul 30  2019 custom
drwxrwxr-x 3 root root 276 Jun  5 16:45 performance-spool

 

 

Resolution

If the certifications and custom folders are missing, the only recourse is to obtain copies of them from:

1. A backup

2. Another install of the same version of the DA that you are currently running

Once they are put into place:

1. systemctl stop dadaemon activemq

2. systemctl start dadaemon