Why do our Palo Alto Firewall devices have a grey tab for Performance metrics in OneClick?
search cancel

Why do our Palo Alto Firewall devices have a grey tab for Performance metrics in OneClick?

book

Article ID: 192427

calendar_today

Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

When we click on our Palo Alto Firewall devices, we notice that the Performance tab is greyed out and it is not possible to get CPU or Memory metrics from OneClick.

Environment

Release : All Supported Releases

Component: SPCCSS - SpectroSERVER Core

 

Cause

By default, Spectrum determines during a discovery, if the device has CPU and Memory attributes by doing a query to the hrSystemMaxProcess, and if the device responds, then Spectrum creates an RFC2790app model and the Performance Tab is enabled.

Resolution

Palo Alto devices do not support the hrSystemMaxProcesses mib attribute which SPECTRUM queries to determine support of the Host Resources MIB. Therefore,
when SPECTRUM queries the hrSystemMaxProcesses attribute it does not get a response and the rfc2790app model is not created.

Even though these devices are certified, some of these devices do not support the attributes which are used to trigger the attachment of appmodels.

 

Please follow the below steps to make sure that the correct Application Model is attached to the device.

Take an OnLineBackup (OLB) before and after this procedure.

1. Launch the Spectrum Control Panel (SCP)

2. Stop the SpectroSERVER application and ensure it is Inactive.

3. Launch the Model Type Editor (MTE) (Configure à Model Type Editor)

4. In the Navigation pane, Model Types TAB, select the rfc2790App, then in the Contents pane, Attributes TAB, select the default_attr_list (0x00230bd3) attribute and click on the Edit button.

5. A new window will open, click on the Edit button.

6. A new window will open, click on the Add button.

7. Type c4072e which is the hrSystemUpTime (0xc4072e) attribute ID. Click the Apply button and then the OK button.

8. Save the change to the SSdb Catalog. Click on File à Commit to Database.

9. Exit from MTE. Click on File à Exit.

10. Start the SpectroSERVER.

11. Reconfigure the Palo Alto device. Select the Palo Alto device, right-click, and select Reconfiguration à Reconfigure Model.
Once the rfc2790app model is created after a successful model reconfiguration, the NRM attributes will get mapped and the Performance Tab will be enabled.

12. You should now see the data in the Performance TAB.

 

This is scheduled to be fixed out of the box with Spectrum 10.4.1 BMP 1 patch and any newer future releases of Spectrum.