SystemEDGE stops responding to SNMP requests after pushing a new VAIM policy that includes extension monitors
book
Article ID: 192394
calendar_today
Updated On:
Products
CA Systems Performance for IM (SystemEdge)
Issue/Introduction
The SystemEDGE agent stops responding to SNMP requests after pushing a new VAIM policy with extension monitors.
Cause
Invalid\problematic extension scripts are causing the agent to hang during policy validation.
Environment
Release : 12.9
Component : VPM GENERAL
Resolution
When a policy is deployed to a SystemEDGE host from VAIM the sysedge.cf file is delivered to the port#/temp directory.
Once the the sysedge.cf file is validated it will be moved into the port# folder.
During the validation process SystemEDGE will attempt to run all extension scripts included in the configuration to make sure they returning the expected result.
Enabling debug on the SystemEDGE host you can see what monitor the agent validation is hanging on and take the appropriate corrective action.
Additional Information
To enable SystemEDGE Debug:
1. Stop Agent 2. Navigate to /opt/CA/SystemEDGE/config/port# folder 3. Edit sysedge.cf and make the following change: sysedge_loglevel debug 4. Start Agent