APM alerts cannot be cleared manually

book

Article ID: 192337

calendar_today

Updated On:

Products

DX Operational Intelligence

Issue/Introduction

Due to vertexes not having state in APM ATC, every alert is triggered as a new instance. If that occurrence is not properly cleared in APM, the alert persists in OI forever.
 
Manual clear does not work as it does with Spectrum.


Cause

APM Alarm life cycle issue is caused due to multithreading issue while we access cache. 

Environment

Release : 1.3.2

Component : CA DOI ALARM ANALYTICS

Case was raised against OI SaaS environment

Resolution

A code change was made to prevent this issue