Remove Old Data Collector from Portal Data Collector List
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Remove Old Data Collector from Portal Data Collector List

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Article ID: 192086

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Updated On:

Products

CA Performance Management Network Observability

Issue/Introduction

After migrating CAPM servers to new hardware and moving all data, the System Health in NetOps Portal still references the previous Data Collector server. The goal is to remove the previous Data Collector that no longer exists from the NetOps Portal view.

During the environment migration, a mistake was made with the Data Collector migration. The new destination system shows both the old and the new Data Collectors on the Data Collector Status page. The old Data Collector appears with all red status indicators and shows the devices and items associated with it. The new Data Collector is shown as green and active but has no items. we need to remove the ghost Data Collector from the system.

Environment

All supported DX NetOps Performance Management releases

Cause

In some instances this is caused when the update_da_dc_database_references.sh script is run with an  incorrect source Data collector name.

Resolution

To remove an old Data Collector (DC) from the NetOps Portal list, follow these steps:

  1. Check DC Status:

    • Ensure that both the old and new DCs are in a Green Normal state.
    • If both DCs are Green Normal, move devices from the old source DC to the new destination DC. This is only possible when both DCs are in a Green Normal state.
  2. Determine the Old DC's ID:

    • Using Browser:

      • Navigate to the following URL in your browser:
         
        http://DA_Host:8581/rest/dcms
         
      • Replace DA_Host with your DA hostname or IP address.
    • Using CLI:

      • Execute the following curl statement:
         
        curl -v -u "admin:admin" -X GET -H 'Content-Type: application/xml' http://DA_Host:8581/rest/dcms
         
      • Replace DA_Host with your DA hostname or IP address.
      • Replace the default admin credentials (admin:admin) with your own if they are different.
    • Note the ID for the DC you want to remove. Be careful to select the correct one.

  3. Delete the Old DC:

    • Using REST API:

      • Issue a DELETE request to the following URL:
         
        http://DA_Host:8581/rest/dcms/ID
         
      • Replace ID with the number from above.
    • Using CLI:

      • Execute the following curl statement:
         
        curl -v -u "admin:admin" -X DELETE -H 'Content-Type: application/xml' http://DA_Host:8581/rest/dcms/ID
         
      • Replace DA_Host with your DA hostname or IP address.
      • Replace the default admin credentials (admin:admin) with your own if they are different.
  4. Confirm Removal:

    • Check the Data Collector Status page in the Portal web UI to confirm the old DC has been removed.

 

Additional Information

Note:

You will need to remove all Monitored Devices (apart from DC itself) from the DC being deleted.

In versions 23.3.12 and lower, deleting the DC with Monitored Devices will leave them without an associated data collector and unable to be moved in the Portal UI.

In 23.3.13 and later you will get an error back if there are monitored devices: 400 Bad Request and the DC will not be deleted.

This was addressed as part of the defect below

Symptom: When an active data collector is accidentally deleted, the inventory discovery is unable to discover the existing devices' IPs even through there are till other data collectors available.
Resolution: With this fix, the data aggregator REST services now prevents the deletion of any active data collector. The discovery now selects other available data collectors for the devices whose data collector was deleted.
(23.3.13, DE605338, 35087641).