websphere_mq profile does not display all queues and channels
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websphere_mq profile does not display all queues and channels

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Article ID: 192041

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

websphere_mq -> Actions ->  "Verify path" works but all channels and queues are not displayed

websphere_mq 
[Data Collector- CBYPWEBE, websphere_mq] Start inventory update resource: %websphere_mq%
[Data Collector - CBYPWEBE, websphere_mq] Failed to execute PCF commandcom.ibm.mq.MQException: MQJE001: Completion Code '2', Reason '2035'.
[Data Collector - CBYPWEBE, websphere_mq] Test Connection failed.Reason : com.ibm.mq.MQException: MQJE001: Completion Code '2', Reason '2035'.
[Data Collector - CBYPWEBE, websphere_mq] PERF: DONE:  websphere_mq inventory update for %websphere_mq% {Seconds=0.044}
[Data Collector - CBYPWEBE, websphere_mq] Inventory update failed. Sending resource alarm
[Data Collector - CBYPWEBE, websphere_mq] (1) error, Inventory update failed for %websphere_mq%E: com.ibm.mq.MQException: MQJE001: Completion Code '2', Reason '2035'.
 at com.nimsoft.probe.framework.genprobe.GenInventory.handleInventoryUpdateException(GenInventory.java:209)

Environment

Release : 9.0.2

Component : UIM - WEBSPHERE_MQ

Cause

This issue is seen when prerequisites for websphere_mq probe are not completely in place

Resolution

Ensure that the designated websphere_mq probe user has the required permissions in WebSphere MQ Monitoring and all prerequisites are in place per link below

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/ca-unified-infrastructure-management-probes/GA/alphabetical-probe-articles/websphere-mq-websphere-mq-monitoring/websphere-mq-ac-configuration.html#concept.dita_66bcd4293a9eb420f77c53a7e5192d5ac8c11322_VerifyPrerequisites