New .NET core 3.1 agent cases one of the sites not to display contents
search cancel

New .NET core 3.1 agent cases one of the sites not to display contents

book

Article ID: 192014

calendar_today

Updated On:

Products

CA Application Performance Management Agent (APM / Wily / Introscope) CA Application Performance Management (APM / Wily / Introscope) INTROSCOPE DX Application Performance Management

Issue/Introduction

New .NET Core 3.1 agent case has one of the sites not displaying contents

IntroscopeAgent shows errors for a number of Application Tools. 

Where Broadcom provided a custom .NET agent that discovered .NET core 3.1 sites that the older agent wouldn't discover (along with decorating frontends).

Error logged on the IntroscopeAgent.log

 [ERROR] [IntroscopeAgent.Agent] IntervalHeartbeat.execute threw executing: Waiting for DynamicSystem.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.

   at com.wily.introscope.autoprobe.dynamic.InstrumentationManager.AnonymousClassWaitForConnectionRunnable.AnonymousClassIServerConnectionNotification..ctor(IAgent agent, AnonymousClassWaitForConnectionRunnable enclosingInstance)

   at com.wily.introscope.autoprobe.dynamic.InstrumentationManager.AnonymousClassWaitForConnectionRunnable.ITimestampedRunnable_execute(Int64 nowInMillis)

Environment

Release : 10.7.0

Component : APM Agents

Cause

Per Engineering, DeepTracing is the culprit

Resolution

Please open a support case and refer: case 31945374  / Defect: DE464165

To obtain a desktop build of the Agent to troubleshoot the DeepTracing conflict:

dotnet-agent-99.99.taurus_dotnet_fixes-20200720.165624-48-dotnet-noinstaller-x64.zip

 

If the problem still continues with the above Agent, Please ensure

introscope.agent.deep.instrumentation.logLevel=DEBUG

and

introscope.nativeprofiler.logBytecode=true

set in the introscopeagent.profile along with agent DEBUG logging enabled when trying to reproduce the problem with this dev build.

Attach the logs to the case. 

 

Additional Information

They had to remove the agent for the site functionality to resume. Please reference older ticket 31885558 where Broadcom provided a custom .net agent that discovered .net core 3.1 sites that the older agent wouldn't discover (along with decorating frontends).