Error: "Replication Failed: 2913" - EDM Indexes not replicating to Cloud Detectors
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Error: "Replication Failed: 2913" - EDM Indexes not replicating to Cloud Detectors

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Article ID: 191888

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Updated On:

Products

Data Loss Prevention Cloud Detection Service Data Loss Prevention Cloud Service for Email Data Loss Prevention Cloud Package

Issue/Introduction

EDM indexes stop replicating to the Cloud Detectors. The EDMs sometimes show as being "corrupt" when viewed in the "Data Profiles" section of the Enforce UI, but even when this is cleared up there are errors replicating the index to any Cloud Detector in the console.

Environment

This affects Directory Connection indexes as well, since they are stored in the same format as EDMs.

Cause

A method for setting the latest version of the index to an "isactive" state was failing, and multiple versions are shown as "active" at that same time.

Error sometimes reported:

Replication Failed: 2913

Resolution

This issue was fixed in 15.7 MP2, as per the Release Notes:

DLP-31740 :: During upgrades, LDAP and detection indexes (for IDM and EDM, for example) were not correctly replicated
to cloud detectors.

In one case, it required the deletion of the EDM profiles from the Cloud and a restart of the Enforce services to re-replicate the EDM profiles successfully.