After enabling the Data Aggregator to use https, sync is showing green but cannot see devices and no data in reports.

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Article ID: 191863

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction



After enabling the Data Aggregator to use https, all users report "No Data to Display" on all screens, even Admin tabs like Monitored Devices.


Cause

The certificate used on the Data Aggregator only has the fully qualified domain name and the Data Aggregator data source is configured with the hostname or vice versa.

Environment

Release : 3.7

Component : IM Reporting / Admin / Configuration

Resolution


Under Administration->Data Sources->Data Sources.

Select and edit the Data Aggregator (DA) Data source.

Change the hostname to match the contents of the certificate subject alternative name if mismatched,

You must also be able to resolve this from CAPC.

Click test and if successful save.

Verify data, etc are present after 1 or 2 sync cycles. It may take some time.

Additional Information

Note the existing DA data source should be changed and saved, the existing DA data source should *never* be removed.