How to update the Vertica / Data Repository IP Address after the system's IP Address is changed
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How to update the Vertica / Data Repository IP Address after the system's IP Address is changed

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Article ID: 191796

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Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

How can we update the Data Repository after the server it is installed on has a new IP address assigned.

How do we change the IP address for the Data Repository if the server is moved to a new subnet?

How can we update the Data Repository after the server it is installed on has a new Host Name assigned?

The Data Repository cluster nodes have had their Host Names changed. What changes are needed?

What changes are needed when the Data Repository cluster nodes have their Host Name changed?

Reconfiguration of IP for Vertica DB

Environment

All supported Performance Management releases

Cause

The server the Data Repository is installed on has had it's IP Address or Host Name changed.

Resolution

These instructions are an overview of a basic IP Address change scenario when using a standard 3 node database cluster.

NOTE: If the Host Name has changed but not the IP Address, the same instructions below apply. Just substitute the Host Name anywhere it references the IP Address and change where needed.

The following Vertica documentation provides addition options for making the IP Address changes.


A sample of a basic version of the command used to change the IP Address is:

  • ./admintools -t re_ip -f <mapfile>


Notes on running the command:

  1. The <mapfile> is a file that has to be created.
    • It does not exist until it is manually created.
    • It must be populated with the correct values.
    • It must be in the correct format.
    • It should contain a mapping of old<->new IP Addresses.
  2. The admintools command is found by default in the /opt/vertica/bin directory.
  3. The admintools command should be run as the dradmin or equivalent Database admin user.
  4. The admintools command can be run from any node in the cluster
  5. The admintools command should be run when all nodes in the cluster are DOWN.
If we were to, for example, create a mapping file named mapping.out in /tmp and cat it to review the contents, it might look like the following sample using example IPs.

[dradmin@DR_Node tmp]$ more /tmp/mapping.out
192.0.2.254 198.51.100.255
192.0.2.255 198.51.100.256
192.0.2.256 198.51.100.257


When making these changes for all Performance Management releases:

  • Review the Data Aggregator file /opt/IMDataAggregator/apache-karaf-<version>/etc/dbconnection.cfg.
  • If the dbHostNames variable value is set with IP Addresses for the Data Repository cluster nodes, update them to use the new IP Addresses.
  • If it uses host names, if they've remained the same no change is needed.
  • If in use for host resolution, ensure the Data Aggregator /etc/hosts file is updated with the new IP Addresses of the Data Repository cluster nodes.

Additional Information

  • Performance Management system service stop and start commands/steps can be found in the following Knowledge Base article. It covers all system components and configurations.
  • All directory paths listed are based on default install paths.
    • Change as needed if utilizing non-default installation home directories.