Update Data Collector after IP Address or Host Name changes
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Update Data Collector after IP Address or Host Name changes

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Article ID: 191779

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Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

How can we update the Data Collector after the server it is installed on has a new IP address assigned.

How do we change the IP address for the Data Collector if the server is moved to a new subnet?

How can we update a Data Collector after the server it is installed on has a new Host Name assigned?

What changes are needed when a Data Collector has it's Host Name changed?

Environment

All supported Performance Management releases

Cause

The server the Data Collector is installed on has had it's IP Address or Host Name changed.

Resolution

Overall the Data Collector will update on Data Collector startup.

  1. It will recalculate the IP Address, hostname, etc during startup.
  2. When the Data Collector starts post IP change on the server it will send new information to the Data Aggregator to record in http://<DA_HOST>:8581/rest/dcms.

There are no product file related changes needed when changing the Data Collector hosts IP Address.

NOTE: If the Host Name has changed but not the IP Address, the same instructions below apply. Just substitute the Host Name anywhere it references the IP Address and change where needed.

  1. Once the new IP Address is active on the host, the new IP Address is picked up after a Data Collector restart.
  2. When changing the IP Address on the Data Collector server take these steps:
    1. Stop Data Collector including the ActiveMQ service
    2. Change IP Address on the server
    3. Start Data Collector service

Disaster Recovery Environment Considerations

  1. If running a Disaster Recovery environment, run the update_da_dc_database_references.sh script to update the Data Repository with the new Data Collector IP Address.
  2. Ensure when setting up the script that the new system IPs are used.
    • Use of the wrong, IE old, IPs will result in problems with possible cross-system communications if both are running.
    • This is capable of causing a myriad of possibly serious issues in the product leading to possible operational or stability failures.

Additional Information

  • Performance Management system service stop and start commands/steps can be found in the How to properly restart the DX NetOps Performance Management environment Knowledge Base article.
    • It covers start/stop steps for all system components and configurations.
  • All directory paths listed are based on default install paths.
    • Change as needed if utilizing non-default installation home directories.

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/performance-management/21-2/administrating/data-aggregator-administration/update-the-data-collector-ip-address-and-hostname.html