Update the Data Aggregator after IP Address or Host Name changes
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Update the Data Aggregator after IP Address or Host Name changes

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Article ID: 191775

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Updated On: 09-23-2024

Products

CA Performance Management Network Observability

Issue/Introduction

How can we update the Data Aggregator after the server it is installed on has a new IP address assigned.

How do we change the IP address for the Data Aggregator if the server is moved to a new subnet?

How can we update the Data Aggregator after the server it is installed on has a new Host Name assigned?

What changes are needed when a Data Aggregator has its Host Name changed?

Environment

All supported Performance Management releases

Cause

The server the Data Aggregator is installed on has had its IP Address or Host Name changed.

Resolution

There are a number of places, on different Performance Management servers, where we need to ensure the new Data Aggregator IP Address is updated. Ensure all areas are reviewed and updated where needed. Failure to do so may result in loss of functionality.

NOTES:

  1. Before making these changes ensure the Data Aggregator and ActiveMQ services are both stopped. Once stopped make the changes and then restart the Data Aggregator. Make sure to restart dcmd AND activeMQ on the DC.
  2. If using a Fault-Tolerant Data Aggregator configuration ensure the correct activate and maintenance state changes are used, not the standalone Data Aggregator stop/start commands.
  3. Overall the Data Aggregator will update on Data Aggregator startup.
    1. It will recalculate the IP Address, hostname, etc during startup.
    2. When the Data Aggregator comes up, it updates the Data Aggregator item with the latest IP Address, and also updates the Name and Host Name to the same IP.
  4. No specific changes are needed for the ActiveMQ service on the DA. It listens on 0.0.0.0, IE: all IPs.

Locations To Change The IP Address

NOTE: If the Host Name has changed but not the IP Address, the same instructions below apply. Just substitute the Host Name anywhere it references the IP Address and change where needed.

  1. Review the following file on all Data Collector hosts that communicate with the Data Aggregator.
    • Check the file /opt/IMDataCollector/apache-karaf-<version>/etc/com.ca.im.dm.core.collector.cfg
      • If collector-manager-da-hostname uses IP addresses for the DA host update it with the new IP address.
      • If collector-manager-da-hostname uses hostname for the DA, if that remains the same no change is needed.
  2. Confirm DNS and/or the /etc/hosts file are configured properly to translate to the new IP for the existing hostname.
  3. Update the Data Aggregator Data Source in the Performance Center Web UI.
    1. Go to Administration->Data Sources->Data Sources. Select the Data Aggregator and select the Edit button.
      • If using Host Name, as long as the PC hosts /etc/hosts file is updated correctly or DNS, no change is needed.
      • If using IP address set the correct new IP address and select Test to validate communications.
    2. If the Test is successful select Save to save the changes.
  4. Edit the networkConnector entries in the ActiveMQ services activemq.xml file on the Data Collectors if they are set using IP Address instead of Host Name.
    • The active version of the activemq.xml file in use is found on the Data Collectors in the directory:
      • /opt/IMDataCollector/broker/apache-activemq-<version>/conf
    • The host specified in the networkConnector entries specify who the Data Aggregator is the Data Collector should communicate with. Normally we'll see Host Name values for the Data Aggregator set instead of IP Address.  There are four of these entries, one for each of the following ports: 61616, 61618, 61620, and 61622.
      • If set with Host Names, as long as DNS and/or /etc/hosts are updated properly with the new IP Address for the Data Aggregator Host no change is needed.
      • If set with IP Addresses, failure to update this will result in communication failures between the Data Aggregator and Data Collectors causing possible data loss.
      • Any entry in the file referencing the DA by IP Address will need to be manually updated to use the new IP Address.
    • In a Fault-Tolerant DA environment, both DA hosts should be listed in each networkConnector entry. Ensure the correct IP Addresses are set for both.
    • The transportConnectors set to 0.0.0.0:61616 should remain unchanged. Do not edit this.

Disaster Recovery Environment Considerations

  • If running a Disaster Recovery environment, run the update_da_dc_database_references.sh script to update the Data Repository with the new Data Aggregator IP Address.
    • Instructions for that script are found here in the Disaster Recovery Scripts
    • Ensure when setting up the update_da_dc_database_references.sh script the new system IPs are used.
      • Use of the wrong, IE old, IPs will result in problems with possible cross-system communications if both are running.
      • This is capable of causing a myriad of possibly serious issues in the product leading to possible operational or stability failures.

Additional Information

  • Performance Management system service stop and start commands/steps can be found in the following Knowledge Base article. It covers all system components and configurations.
  • All directory paths listed are based on default install paths.
    • Change as needed if utilizing non-default installation home directories