APi Gateway - PAPIM - APM 10.7 - DSE: EM log flooded with "Vertex ... has too long value"
search cancel

APi Gateway - PAPIM - APM 10.7 - DSE: EM log flooded with "Vertex ... has too long value"

book

Article ID: 191538

calendar_today

Updated On:

Products

CA API Gateway API SECURITY CA API Gateway Precision API Monitoring Module for API Gateway (Layer 7) CA API Gateway Enterprise Service Manager (Layer 7) STARTER PACK-7 CA Microgateway

Issue/Introduction

In our standalone EM APM environments (version xx.xx.xx.xxx(Build 995603)) the EM logs are currently flooded with very large messages about vertices with values that are too long, e.g.
“4/28/20 02:29:31.796 PM UTC [WARN] [AppMapAsyncExecutor-7] [Manager.ATC.DAO] Vertex with id 66082 has too long value ($JSON{["0","100157", …”
 
We suspect this issue might be related to the PAPIM APM integration for API Gateway. The appearance of these log lines correlates with the implementation of the PAPIM integration in our environments.
 
 

Environment

Release : 9.4

Component : Integration with APM
APM 10.7.0.258
 
OS: Red Hat 7.8

Cause

The root cause is an issue in PAPIM integration, by design the integration sends the "Request Size(bytes)" and "Response Size (bytes) as "Attributes" 

however, these attributes keep changing continuously, so it causes the below WARN messages in the EM log:


The solution to this issue is to report the "Request Size(bytes)" and "Response Size (bytes)" as Metrics instead of "Attributes"

Resolution

APIM has to stop sending request and response size as attributes in traces to APM. As trace properties they are perfectly fine, just remove the "ATTR_" prefix!

This is a defect; however, the workaround is given ..

The below change ensures the collected traces containing the Request Size and Response Size parameters without the ATTR prefix. It is based on find and replace using simple Evaluate Regular Expression assertion. Change is provided to the Layer7 Gateway policy and hence it will be immediately into effect as soon as the changed policy is saved and activated. 

Note: Take a backup of the policy prior to editing it.

 

Steps to follow:

  1. Connect to the Layer7 Gateway using Policy Manager
  2. Select and expand the APM_Metrics folder in the Services/Policies tree
  3. Open APM_Traces policy
  4. Find out the Get Latency Metrics at Assertion Level assertion (Most likely at line 5) and Select it
  5. Select it and paste (Ctrl + V or Right Click and choose Paste option from the context menu)
  6. Copy the content of the attached template policy (regex.template.policy.xml) and paste it (Ctrl + V or right-click and choose Paste option from the context menu)
  7. You will see a new assertion (Evaluate Regular Expression) populated next to the assertion selected above.
  8. Save and Activate the policy from the Policy Editor toolbar

 

Attachments

1590502711134__regex.template.policy.xml get_app