Agent not starting with error code='43' in Service Manager log
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Agent not starting with error code='43' in Service Manager log

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Article ID: 191524

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Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation

Issue/Introduction

After installing a new agent it doesn't start and does not create a log file.

The Service Manager (SMgr) log reports:

20200526/062831.127 - U00022019 Client statement: process 'AGENT' should be started.
20200526/062831.127 - U00022031 Client data: User 'DOMAIN\USER' of computer 'COMPUTER_NAME'.
20200526/062831.127 - U00022004 Starting process 'AGENT' ...
20200526/062831.127 - U00022005 ... with command line  '/usr/bin/java -jar /opt/sap/agent/bin/ucxjr3x.jar -i/opt/sap/agent/bin/ucxjr3xi_AGENT_3.ini'.
20200526/062831.127 - U00022006 ... and start directory  '/opt/sap/agent/bin/'.
20200526/062831.128 - U00022007 Process 'AGENT' (ID '14717') successfully started.
20200526/062831.573 - U00022012 Process 'AGENT' (ID '14717') ended.
20200526/062831.573 - U00022022 Process 'AGENT' ended, exit code='43'.

Environment

Release : v12.1 / v12.2 / v12.3

Component : Agent

Cause

The ini-file with the name indicated in the -i parameter doesn't exist

Resolution

Refer to an existing ini-file in the -i parameter