SAM: Problem with check installation
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SAM: Problem with check installation

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Article ID: 191449

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Updated On:

Products

CA IT Asset Manager CA IT Asset Manager Asset Portfolio Management CA Software Asset Manager (CA SAM) ASSET PORTFOLIO MGMT- SERVER

Issue/Introduction

Problem with check installation.  During the install of SAM, during Check Installation, an error may present that states in the check_installation log that Parallel Processing or Parallelization check has failed:

2020-05-07 10:43:54     26 MB  INFO         start requirements for parallel processing
2020-05-07 10:43:54     26 MB  INFO           mode for inter-process communication: filesystem
2020-05-07 10:44:59     26 MB  ERROR          asp_retry->throw_non_transient_exception(): failed. error: error code: [500001], error message: [producer->assert_handshake(): failed. error: Handshake with consumers failed because only 0 of 2 consumers did send an acknowledgement]

Environment

Release : 4.4

Component : CA SOFTWARE ASSET MANAGER

Cause

The given instance did not have any DB parameters defined in the config.ini

Resolution

In all instances, a backend database needs to be established for the Check Install to run and pass on the Parallel Processing or Parallelization check.  One can either create a temporary/dummy database or have the actual database content from an existing SAM instance imported to a database for the given SAM install to work against.

Additional Information

See also the following tech doc for recommended instructions to install SAM:

https://knowledge.broadcom.com/external/article?articleId=131421

Above includes instructions on how to create a dummy database for SAM to operate with.