Agile Sync Error Could not sync milestones - HTTP/1.1 524 Origin Time-out
search cancel

Agile Sync Error Could not sync milestones - HTTP/1.1 524 Origin Time-out

book

Article ID: 191436

calendar_today

Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

It fails when executed from the Project / Agile Summary actions menu, but checking the last scheduled job run for the Synchronize Agile Central job, it may execute normally.

Related error:

Failure: java.lang.Exception: Could not sync milestones 
 at com.ca.ppm.agl.services.ProjectSyncManager.syncMilestones(ProjectSyncManager.java:520)
 at com.ca.ppm.agl.services.ProjectSyncManager.sync(ProjectSyncManager.java:120)
 at com.ca.ppm.agl.jobs.AGLProjectSync.run(AGLProjectSync.java:89)
 at com.niku.njs.AbstractClarityJob.scheduledEventFired(AbstractClarityJob.java:74)
 at com.niku.njs.Dispatcher$BGTask.run(Dispatcher.java:657)
 at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
 at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
 at java.base/java.lang.Thread.run(Thread.java:834)
Caused by: java.io.IOException: HTTP/1.1 524 Origin Time-out
 at com.rallydev.rest.client.HttpClient.executeRequest(HttpClient.java:163)
 at com.rallydev.rest.client.HttpClient.doRequest(HttpClient.java:145)
 at com.rallydev.rest.client.ApiKeyClient.doRequest(ApiKeyClient.java:37)
 at com.rallydev.rest.client.HttpClient.doGet(HttpClient.java:221)
 at com.rallydev.rest.RallyRestApi.get(RallyRestApi.java:199)
 at com.ca.ppm.rally.service.PortfolioItemService.getMilestones(PortfolioItemService.java:605)
 at com.ca.ppm.agl.connector.RallyConnector.getMilestones(RallyConnector.java:167)
 at com.ca.ppm.agl.services.ProjectSyncManager.syncMilestones(ProjectSyncManager.java:482)
 ... 7 more

Environment

Release : All Supported Releases

Component : CA PPM SAAS RALLY

Cause

  • The 524 error generates when a request takes longer than 4 minutes, so it can have multiple causes
  • Rally Database issues
  • Temporary network issues etc.

Resolution

  • Check with the network team, about any issues that might have occurred around the time stamp that gets logged in the Clarity logs
  • Raise a case with Broadcom Support, for Rally product, and provide the time stamp around which the issue occurred.

Additional Information

  • See also 134283 - Rally Sync Job Error: Could not add milestone with 504 Gateway Time-out or 502 Proxy Errors
  • See KB: 141061 for tips on how to optimize use of Self Service for Clarity