APM agent name appended with %1 in DX SaaS Environment
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Article ID: 191364
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Updated On:
Products
CA Application Performance Management SaaS
Issue/Introduction
Some agent names for our tenants are appended with "%1" intermittently. I was going through the threads related to this problem on the community forum and as I understand, this happens when we restart the WebSphere/Java process and the EM doesn't disconnect from the agent in time to register the agent again.
The previous threads mentioned that adding the following property to EM should resolve the problem. introscope.enterprisemanager.metadata.autoexpire=false
As we are using the SaaS version, and have no control over EM. Is there any alternate way to avoid this?
Environment
Release : SAAS
Component : APM Agents
Cause
Configuration should be done from the Agent side.
Resolution
Per Engineering, this can be done from the Agent side in DX SaaS environment.
Here are a couple of options:
1. First, if the monitored application would have two instances running at the same time momentarily during its restart. Avoid the overlapped process instances by allowing the existing process to exit first before restarting a new one.
2. If the issue still continues, below are the agent properties that can be considered to increase the delay in autonaming to see if it helps mitigate the situation:
This property specifies the number of seconds that an agent waits for naming information before connecting to the Enterprise Manager. Default:120 Example:introscope.agent.agentAutoNamingMaximumConnectionDelayInSeconds=120 Note:Restart the managed application for changes to this property to take effect.
This property specifies the number of minutes that an agent waits before determining whether it has been renamed. Default:10 (minutes) Example:introscope.agent.agentAutoRenamingIntervalInMinutes=10 Note:Restart the managed application for changes to this property to take effect.