Occasionally when trying to provision an account in Office365 failure with error: O365: Failed to modify hybrid account.
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Occasionally when trying to provision an account in Office365 failure with error: O365: Failed to modify hybrid account.

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Article ID: 191320

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Identity Suite

Issue/Introduction

Hi,

In some cases when IDM  try to provision an account in Office365 show this error: O365: Failed to modify hybrid account.

Complete error message:

Cause: User 'euser@<example>.com' on 'Office365' creation failed: Connector Server Add failed: code 80 (OTHER-NamingException): failed to add entry eTDYNAccountName=euser@<example>.com,eTDYNAccountContainerName=Accounts,eTDYNDirectoryName=Office365,eTNamespaceName=Office 365,dc=im,dc=etasa: javax.naming.NamingException: JCS@365hostname: O365: Failed to modify hybrid account [euser@<example>.com]. [] (ldaps://<IP>8:20411) Action: Assign user "<sampleuser> (C1000395215)" provisioning role "Office365 E1 - ADSync"


2020-04-27 11:37:29,357 1327922488 [ApacheDS Worker-thread-118] (com.ca.jcs.core:com.ca.jcs.osgi.exchange.router.MessageRouter:551) ERROR  - A remote server returned an error: org.apache.directory.shared.ldap.exception.LdapNamingException: JCS@SVRPP01: JNDI: JCS@SVRPP01: O365:  Failed to modify hybrid account [[email protected]]. [] [Root exception is javax.naming.NamingException: JCS@SVRPP01: O365:  Failed to modify hybrid account [[email protected]]. []]
2020-04-27 11:39:01,862 1328014993 [ApacheDS Worker-thread-39] (com.ca.jcs.csproxy:com.ca.jcs.csproxy.CSProxyActivateConnectorProxy:136) WARN   - Error with operation : doSearch, activating and retrying
javax.naming.NameNotFoundException: [LDAP: error code 32 - No Such Object]; remaining name 'eTADSOrgUnitName=Administrators,eTADSDirectoryName=AD_Production,eTNamespaceName=ActiveDirectory,dc=im,dc=etasa'

 

Environment

Release : 14.2

Component : CA IDENTITY SUITE (VIRTUAL APPLIANCE)

Cause

This was due to having upgraded the VAPP environment, but not upgrading the Connector Server itself.

Resolution

The resolution was to ensure all connector servers are upgraded to the same version of the overall Suite software.