CA Service Desk ManagerSUPPORT AUTOMATION- SERVERCA Service Desk Manager - Unified Self ServiceCA Service Desk Manager - Mobile ApplicationCA Service Desk Manager - Xtraction
Issue/Introduction
While configuring or starting up the SDM application, the SDM Service is stopping on its own. The stdlogs are displaying messages such as:
05/20 11:38:51.15 SERVER1 pdm_d_mgr 5920 EXIT api.c 1760 Exiting because slump server terminated!
No indication for a specific process dying or experiencing an error, ie in the above, the rep_daemon process is disconnecting, despite no other indicators in the SDM stdlog to suggest that it has ERROR, died, or EXIT. Log shows that the slump service is terminating and is in an EXIT state.
Environment
Release : 17.1
Component : SERVICE DESK MANAGER
Cause
The given server's anti-virus or an external monitoring application may be terminating the process as a perceived threat.
Resolution
One should review the Anti-virus or security logs to determine if any processes in the SDM install directory are being flagged for termination. The logging may denote the rep_daemon.exe process as the threat in this case. If so, the given process should be marked as an exception. Ideally, all of the SDM install bin directory and attachment folders should be marked as exception.
Additional Information
Service Desk does not have any certifications for interoperability with any security products. This is due to the high variability of such products in how they can be configured to detect a given threat. Guidance on how to configure SDM to override the given security product is not available as that would defeat the purpose of a security product's intent.