Clarity : Custom Processes using XOG are not working after upgrade
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Clarity : Custom Processes using XOG are not working after upgrade

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Article ID: 191078

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Updated On:

Products

Clarity PPM SaaS

Issue/Introduction

We have a custom process which uses XOG to perform different operations on the application. It stopped working after upgrade

Environment

Release : 15.7.1

Component : CA PPM SAAS BUSINESS PROCESS MANAGEMENT

Cause

This is caused by a validation in the GEL script for XOGPASSWORD == null when using the Clarity PPM inbuilt session generator.

The session generator only returns the username and session id and doesn't return any password.

Resolution

We made modifications to the code of the processes to exclude checks for XOG password == null.