Wildfly Agent cannot connect to EM
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Wildfly Agent cannot connect to EM

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Article ID: 191074

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Updated On:

Products

CA Application Performance Management Agent (APM / Wily / Introscope) CA Application Performance Management (APM / Wily / Introscope) INTROSCOPE DX Application Performance Management

Issue/Introduction

Infrastructure Agent connects but the Java Wildfly agent cannot connect to the Standalone Enterprise Manager.   
The agent never appears in the Investigator, and the Introscope Agent log shows that it continually connects, downloads and accepts a new list, but then loses contact
([WARN] [IntroscopeAgent.IsengardServerConnectionManager] Lost contact with the Introscope Enterprise Manager at (EMHostname:5001.) 
This cycle repeats every 10 seconds.

Environment

Release : 10.7.0

Component : APM Agents

Cause

Incorrect Java path prevents the agent from connecting.

Resolution

Provide the correct Java path for the Wildfly Agent