Data Aggregator Synchronization Failure
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Data Aggregator Synchronization Failure

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Article ID: 191064

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Updated On: 03-13-2025

Products

CA Performance Management Network Observability

Issue/Introduction

After restarting the DA we see in status it is running, but it cannot synch in NetOps Portal data sources
 
The following is seen when you click on Data Aggregator, and then "Log" on the data source list.  "A processing failure occurred on the data source during synchronization"
 
The following is seen in the (default path) /opt/CA/PerformanceCenter/DM/logs/DMService.log file.
 
ERROR | pool-2-thread-5          | 2018-01-07 00:07:38,141 | com.ca.im.portal.dm.productsync.DataSourcePoller
      |
Invalid or incomplete information was provided to CAPC during sync with data source Data Aggregator@<DAHostName>.  The problem is in the data source, not CAPC.  A full sync of the data source may resolve the problem.  Additional information is provided below:
DataSource Data Aggregator@xxxxx has sent items with unknown subtypes:
1 items of type component and subtype AllEngines
1 items of type component and subtype Engine

Environment

All supported DX NetOps Performance Management versions

Cause

Even though the dadaemon process is running (systemctl status dadaemon) it is not responding.

Resolution

To resolve the issue take the following steps for a single standalone Data Aggregator. Default install home paths are shown.
  1. Stop the dadaemon service using the command:
    1. systemctl stop dadaemon
  2. Stop the activemq service using the command:
    1. systemctl stop activemq
  3. Run the following command:
    1. /opt/IMDataAggregator/scripts/dadaemon clean
    2. Note: If using a version that doesn't recognize the clean argument take these steps instead.
      1. Rename the /opt/IMDataAggregator/apache-karaf/data directory to /opt/IMDataAggregator/apache-karaf/data.old. A new one will be created on restart.
      2. Delete the file /opt/IMDataAggregator/apache-karaf/deploy/local-jms-broker.xml file. A new one will be created on restart.
  4. Start the dadaemon service. It should restart ActiveMQ for us.
    1. systemctl start dadaemon
  5. Check status to confirm both started using:
    1. systemctl status dadaemon
    2. systemctl status activemq

Additional Information

To verify the DA is responding run this command on the DA CLI.

  • curl -kv -u ADMIN-USER http://YOUR-DA:8581/rest/dataaggregator

NOTE: Replace ADMIN-USER with an admin level user from NetOps Portal console.

NOTE: Replace YOUR-DA with your DA name or IP address.

Enter the specified users password when prompted.

Successful response shows an XML body with content referencing the Portal host the DA connects to, among other config values.