Data Aggregator Synchronization Failure
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Data Aggregator Synchronization Failure

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Article ID: 191064

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Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

After restarting the DA we see in status it is running, but it cannot synch in NetOps Portal data sources

Environment

Dx NetOps Performance Management any version

Cause

Even though the dadaemon process is running, it is not responding.

Resolution



1) Stop the dadaemon service:

systemctl stop dadaemon

2) Stop the activemq service 

systemctl stop activemq

3) Run:

/opt/IMDataAggregator/scripts/dadaemon clean

Note that if you are on a version that does not recognise the clean argument the run:

Rename the/opt/IMDataAggregator/apache-karaf/data To /opt/IMDataAggregator/apache-karaf/data.old

delete the file /opt/IMDataAggregator/apache-karaf/deploy/local-jms-broker.xml

4) Restart  activemq/dadaemon:

systemctl start activemq
systemctl start dadaemon

 

Additional Information

To verify the DA is responding run this command on the DA

  • curl -kv -u ADMIN-USER http://YOUR-DA:8581/rest/dataaggregator

replace ADMIN-USER with an admin level user from NetOps Portal console.

replace YOUR-DA with your DA