How can we verify the data reported by the Perfmon Collector Agent?
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How can we verify the data reported by the Perfmon Collector Agent?

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Article ID: 190927

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Updated On:

Products

CA Application Performance Management Agent (APM / Wily / Introscope) CA Application Performance Management (APM / Wily / Introscope) INTROSCOPE DX Application Performance Management

Issue/Introduction

We are using the .Net Perfmon Collector Agent and the results we are seeing do not seem logical - for example we are seeing peaks in the disk queue length but the read and writes per second data is showing no activity.

Environment

Release : 10.x

Component : APM Agents

Cause

The Perfmon Collector Agent simply reports the counter values that are published by the Windows PerfMon service.

The counters that are monitored are defined in the IntroscopeAgent.profile by the following property 

introscope.agent.perfmon.metric.filterPattern=|Processor|*|*,|.NET Data Provider*|*|*,|.NET CLR*|{osprocessname}|*,|.NET CLR Data|*|*,|Process|{osprocessname}|*,|ASP.NET*|*

Resolution

To verify the data values use the Windows Perfmon tool and add the appropriate counters to it's display



It will then be possible to compare the data reported in APM with that natively displayed in the PerfMon tool in windows.

One point to note is that the Perfmon Collector Agent takes discrete data samples as defined by the following agent property

# Intervals in which Perfmon metrics are collected.  Default is 15 seconds.
introscope.agent.perfmon.metric.pollIntervalInSeconds=15

So this should be taken into account when making comparisons as the PerfMon tool in Windows reports continuously.

Additional Information

The following external link explains adding counters to PerfMon in more detail

https://www.windowscentral.com/how-use-performance-monitor-windows-10

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