Client Automation - Configuration Policy not applied on Agents
search cancel

Client Automation - Configuration Policy not applied on Agents

book

Article ID: 190926

calendar_today

Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

The configuration policy is not applied on some agents and remain in job configuration policy remains in waiting status

Environment

Client Automation - All Versions


Cause

Problem could occur if plugin ccsmagt is not running on Agent machine.



In file C:\Program Files (x86)\CA\DSM\logs\TRC_CSMAGENT*.log following error appears :

ccsmagt|csmtrace|ccsmagent.cpp|000815|ERROR  | # LoadConfig() ### Error 10 loading state list 'C:\Program Files (x86)\CA\DSM\Agent\CCSM\states.xml' ###

Resolution

- Check if file C:\Program Files (x86)\CA\DSM\Agent\CCSM\states.xml exists or is not corrupted.

- Create or update this file with following contents (for DSM Agents) :

<states>
<file nextrun="0">ccnfreportdelta.xml</file>
<file nextrun="0">ccnfparamrequest.xml</file>
</states>


- Start ccsmagt

caf start ccsmagt