Same PX (Policy Xpress) policy may be triggerred multiple times due to duplicate jar files
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Article ID: 190691
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Updated On:
Products
CA Identity ManagerCA Identity GovernanceCA Identity PortalCA Identity Suite
Issue/Introduction
Identity Manager triggers multiple executions of same PX (Policy Xpress) policy.
I have a task that supposes to trigger a PX policy once. The PX policy contains DB calls or sending email action. However, I can observe multiple executions of the same PX policy and users are getting multiple same emails.
Environment
Release : 14.x
Component : IdentityMinder(Identity Manager)
Cause
This issue may be caused by existing backup or duplicate jar files in below Identity Manager deployment's library directories \iam_im.ear\library \iam_im.ear\user_console.war\WEB-INF\lib
The common mistake is renaming the jar files' filename with intention to backup before applying patches (new jar files). So, for example, the following backup/duplicate jar files are left residing under above directories identitymanager.jar_5_12 identitymanager.jar_5_4 user_console.jar_5_12 user_console.jar_5_4
Although the extension of the file is not exactly .jar, this may cause problem.
Resolution
You should move out those duplicate/backup jar files from the above deployment's library directories. If you need to backup them, store the backup jar files out of Identity Manager deployment directory and restart Identity Manager.