How to manage SNMP Community String changes in Performance Management
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How to manage SNMP Community String changes in Performance Management

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Article ID: 190546

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Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

If the Community String devices use is changed, how can we update DX NetOps Performance Management and the Data Aggregator with those changes?

All devices using a common Community String and SNMP Profile in DX NetOps Performance Management had their Community String changed. How can we update DX NetOps Performance Management with that change?

Some devices using a common Community String and SNMP Profile used by all devices had their Community String changed. How can we update DX NetOps Performance Management with that change?

We have add a new SNMP Profile with a new Community String that replaces an old one on many devices. They have started to show data gaps instead of using the new SNMP Profile. Why is it not using the new SNMP Profile? How can we make it use the new SNMP Profile?

Environment

All supported DX NetOps Performance Management releases

Cause

The SNMP Community String set on devices has been changed.

Resolution

The SNMP Profiles documentation topic section titled 'SNMP Profile Changes' details how this functionality operates. It states the following.

Additional details about how this functions.

  • By default if we have 2 failed polls in a row we will attempt a profile rediscovery. It does this by rerunning the Discovery Profile pointed to by DiscProfileID on the device.
    • This is the Discovery Profile initially used to discover the device.
    • The DiscProfileID is visilable via these REST APIs:
      • DA_HOST:Port/rest/devices/manageable/<DA_DeviceItemID>.
      • DA_HOST:Port/rest/devices/<DA_DeviceItemID>.
  • If the Discovery Profile referenced by DiscProfileID still exists, it uses the list of SNMP Profiles specified in that Discovery Profiles configuration to attempt successful SNMP communication.
    • If the Discovery Profile doesn't contain the new SNMP Profile in it's configured list it will not try to use it.
    • If the Discovery Profile is configured to use all SNMP Profiles available to the system, it would try to use it.
  • If the Discovery Profile referenced by DiscProfileID doesn't exist anymore we use all SNMP Profiles available to the system.
    • They are attempted in the order specified in PC Portal per the Manage SNMP Profiles page (Administration->Configuration Settings).

Do you have a device that uses a new SNMP Community String that is not using the new SNMP Profile configured with the new Community String? It may be due to one of two common causes.

  1. Does the original Discovery Profile used to discover the device exist? Does the Discovery Profile use a specific list of SNMP Profiles or does it use all available SNMP Profiles?
    • If it uses a specific list add the new SNMP Profile to the list and save the changes.
    • At the next internal the Discovery Profile rediscovery run, after two new failed poll cycles, it should result in the device using the new SNMP Profile.
  2. Does the original Discovery Profile used to discover the device no longer exist?
    • It should attempt all available SNMP Profiles until one is found with successful SNMP responses.
    • If it is not doing so the Discovery Profile still exists and is missing the new SNMP Profile needed.