Rally Images and attachments no longer visible or accessible on a work item. Some users can't see the attachment on an artifact.
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Article ID: 190428
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Updated On:
Products
Rally On-PremiseRally SaaS
Issue/Introduction
An image or attachment that was previously visible or accessible on a work item no longer shows. Either the image is gone entirely, or a broken image placeholder is shown. Revision history on the work item may also show a broken image placeholder.
This can be caused under the following circumstances:
A work item is copied and the original work item is deleted
A work item was copied and the original work item is in a project the user doesn't have access to
A single image is copied from one work item and pasted into another work item and the original work item is deleted
An attachment was copied from another work item in a different project and the user doesn't have access to the project
An attachment was copied from another work item then the work item was moved to another project that the user doesn't have access to
Cause
This is caused due to the method Rally uses to internally maintain attachment references. The attachment becomes linked to the original work item and permissions and accessibility are based on that original work item. If the original work item is deleted, or the original work item exists in a project that a user does not have access to, then the attachment in the copied work item will not be accessible. This can affect inline images within description fields as well as attachments such as documents associated with the defect.
Resolution
In order to ensure this is not an issue when copying a work item, it is necessary to upload the attachments to the new work item as a separate step.
If the original image is no longer available on disk, it may be possible to recover the original work item from the Rally recycle bin, save the image from there and then use that saved image to upload to the new work item.
If the original image is in a work item that is in a project that the user doesn't have access to, then either copying that image from the original work item to the new work item, or granting the user access to the source project will resolve the issue.
If an attachment can only be seen by Workspace or Subscription Administrators this is because these attachments were copied and pasted from another artifact in a different project or that original artifact was moved to another project that the editor user doesn't have access to.
It would be possible to figure this out by adding projects to the editor userid until you determine which project the attachment belongs to.
This can be resolved by
A Workspace or Subscription Admin can re-add these attachments correctly to the artifact so all users can see them.
Give the users with the issue access to that project.
It is recommended to find out which user(s) is/are adding the attachments and working with them on how to add attachments by downloading the image to their computer and THEN uploading the image to the artifact. The revision history of the artifact will show which user added the attachments.