CCS error 'Job Exception Occurred' 'An error occurred while retrieving data for target <name>'
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CCS error 'Job Exception Occurred' 'An error occurred while retrieving data for target <name>'

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Article ID: 190366

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Updated On:

Products

Control Compliance Suite Standards Server Control Compliance Suite

Issue/Introduction

Control Compliance Suite (CCS)

A CCS manager seems to be able to do some functionality successfully, i.e. it will run a Fetch Registered Agents job, but when it is used to run a Data Collection or CER job on its own agent, or any other agent, it will fail with the following error.

'Job Exception Occurred'   'An error occurred while retrieving data for target <name>'

 

Environment

Release : CCS 12.5.x, 12.6.x

Component : CCS Manager

Cause

The CCS Certificate on that CCS manager has problems or has become corrupted.

Resolution

Follow these steps to unregister the CCS Manager, unbind and delete the existing certificate, and create a new certificate and reapply it to the manager.

1) Unregister the CCS Managers from the Application Server (make a note of what CCS roles that were assigned to that manager before you unregister it).

  • In Settings > Deployment view, select Infrastructure Tasks dropdown > Unregister CCS Manager. In the Unregister dialog, check the CCS Manager you wish to remove. Click Next.  Check the acknowledge checkbox and click Finish.


2) Make sure you login using the CCS Service Account to the Application Server.  On the Application Server, Click Start > All Programs > Symantec Corporation > Certificate Management Console. In Certificate Management Console, select the CCSManager-<servername> for the manager that you just removed from the CCS console in step 1.  First 'Unbind Certificate' (it may be already unbound) and then 'Remove certificates'. 

3) Now you have to create a new certificate for the CCS Manager. In Certificate Management Console select Create Certificates. Choose Service Type: CCS Manager and complete the other fields including the NetBIOS/FQDN for the CCS Manager machine. Make note of the destination folder as this is where the new certificate will be created.

4) Copy the specific <managername>.p12 certificate to the associated CCS Manager. Place it in an easily accessible directory locally on the CCS Manager.

5) On the CCS Manager launch a command prompt (Run the command prompt 'as Administrator') and browse to the SymCert directory, typically at C:\Program Files (x86)\Symantec\CCS\Reporting and Analytics\SymCert\.

  • Run the command below in the command prompt to replace the old certificate on the manager with the new certificate:
    • SymCert command=Install file="<path_to_new_certificate>.p12" type=1 password=<password> DeleteExistingCert=true pause=true
    • NOTE: The password may be omitted from the command above in order to be prompted for it.


6) To add that CCS manager back to the environment with the new certificate, log in to the CCS Console:

  • Go to
  • Settings > Deployment view, select Infrastructure Tasks dropdown > Register CCS Manager. In the Register a new CCS Manager dialog, check the CCS Manager and click Next. Select the site to associate to the CCS Manager with and click Next. Select the Roles that the CCS Manager will have. Select the Data sources that the new manager will access and click Next. Click Finish and Finish. The CCS Managers should now be working with the new certificate.