CCS 12.x.x error when running an 'Import assets and agents' job - 'Warning: Unable to retrieve message based content information for Agent [Agent Name].'
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CCS 12.x.x error when running an 'Import assets and agents' job - 'Warning: Unable to retrieve message based content information for Agent [Agent Name].'

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Article ID: 190335

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Updated On:

Products

Control Compliance Suite Standards Server Control Compliance Suite

Issue/Introduction

Control Compliance Suite (CCS)

In CCS, when running the 'Fetch Registered Agents' built-in job (or any custom 'Import assets and agents') job, the agents that have been registered to the CCS Managers import correctly but you get the following error in the CCS console associated with the job:

Message: Error while processing agent asset xml
Details:  Warning: Unable to retrieve message based content information for Agent <Agent Name>.

Example:

Environment

Release: CCS 12.x.x

Component :CCS Console

Cause

This warning will appear if the Message Based Content (MBC) was not installed on the agent.  MBC is the legacy collection method used by Enterprise Security Manager (ESM) that is no longer supported.  Raw Based Collection (RBC) replaced MBC for data collection for CCS scans.  

Resolution

This warning can typically be ignored as MBC is no longer supported for data collection.

RBC is the supported data collection method for CCS 12.5.x and 12.6.x, and even though this error is reported the RBC data collection will work correctly.