Running SYSVIEW 15.0, z/OS 2.4, after an IPL, SYSVIEW and SYSVUSER come up completely. A minute later, CICS starts and puts out these messages:
+GSVC720I CA SYSVIEW for CICS request started +GSVC714I INITPARM parms: GSVI=*,USERID=*,START=*,SSID=* +GSVC714I Request parms: GSVS START=WARM +GSVC713I Starting transaction GSVI +GSVC700I CA SYSVIEW for CICS initialization started +GSVC720I CA SYSVIEW for CICS request complete +GSVC024I (GSVI) CA SYSVIEW Performance Management +GSVC001I (GSVI) CA SYSVIEW for CICS Release 15.0 Build 0980 Feature PTF SO06572 +GSVC002I (GSVI) Copyright (C) 2018 CA Technologies, Inc. +GSVC003I (GSVI) Z/OS Release = SP7.2.4 System name = TESTE +GSVC004I (GSVI) CICS Release = 7.0.0 HCI7000 +GSVC050I (GSVI) System configuration options loaded for SSID GSVX +GSVC034I (GSVI) WARM start has been initiated +GSVC027I (GSVI) (GSVI) Services Userid = CICST1 +GSVC025I (GSVI) (GSVS) Initialization Tranid = GSVS +GSVC025I (GSVI) (GSVT) Initialization Tranid = GSVT +GSVC025I (GSVI) (GSVI) Initialization Tranid = GSVI +GSVC025I (GSVI) (SYSV) Online Tranid = SYSV +GSVC172I (GSVI) G-PVT limit has been increased from 6G to 6.06G +GSVC401I (GSVI) zIIP environment - Release 01.90003 +GSVC403I (GSVI) zIIP environment - 8 CPs defined 1 online +GSVC403I (GSVI) zIIP environment - 4 IIPs defined 2 online +GSVC039I (GSVI) Extended CPU monitoring is enabled +GSVC072E (GSVI) CICSDATA subtask has not completed initialization for SSID=GSVX +GSVC069E (GSVI) SYSVIEW environment is not available. Connection will automatically be retried.
After bouncing both SYSVIEW and SYSVUSER, the CICS initialization works fine. Why wouldn't it connect in the first place?
Environment
SYSVIEW 15.0 & 16.0 - z/OS supported releases -
Cause
The CAS9 procedure was not started before SYSVIEW startup.
Resolution
1. Looking at the first start of SYSVIEW (post IPL), there are error messages:
11.35.42 STC08834 GSVX618E (DATALIB) Module CAIRIMC not found <== CAS9 is not started! 11.35.42 STC08834 GSVX619E (DATALIB) CA Common Services not installed 11.35.42 STC08834 GSVX617E (DATALIB) LMP code validation service unavailable, ... 11.35.45 STC08834 GSVX532E (SERVER) #RIMSTAT FLOID failed, rc 00000008 11.35.45 STC08834 GSVX617E (SERVER) LMP code validation service unavailable, ... 11.35.54 STC08834 GSVX637I (MAIN) CICSLOGR task attached ... 11.35.54 STC08834 GSVX570I (CICSLOGR) CICSLOGR task initialization started 11.35.54 STC08834 GSVX532E (CICSLOGR) #RIMSTAT FLOID failed, rc 00000008 11.35.54 STC08834 GSVX617E (CICSLOGR) LMP code validation service unavailable,
This is not correct and this means that CAS9 is NOT properly started in this environment and CICSLOGR and CICSDATA are not connected to any logstreams.
CAS9 must be started BEFORE SYSVIEW, the order of these products should be checked at IPL time:
First the security product, then CAS9, followed by SYSVIEW...
2. Looking at the second start of SYSVIEW, once it is bounced:
There are NO error messages about CAS9 and CICSDATA and CICSLOGR are connected to their logstreams:
13.38.58 STC08911 GSVX271I (CICSDATA) CICSDATA connected to log stream GSVX.SYSDATA.PLOT.SANT type CICSDATA.PLOT.... ... 13.38.59 STC08911 GSVX271I (CICSLOGR) CICSLOGR connected to log stream GSVX.CICSLOGR.EITL.SANT type CICSLOGR.EIT
It is mandatory that CAS9/CAIRIM is initialized BEFORE SYSVIEW.
CA SYSVIEW does check the options installed and the presence of the LMPKEYS, this problem is causing these messages.
CAIRIMC and FLOID are the LMPKEY checking modules and that check was failing during the first start of SYSVIEW.