Validated domain becomes invalid after being used successfully
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Validated domain becomes invalid after being used successfully

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Article ID: 190057

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Updated On:

Products

Data Loss Prevention Cloud Service for Email Data Loss Prevention Cloud Package

Issue/Introduction

The domain in use was added successfully in the past, but has become an 'invalid entry' in Enforce.

The TXT record is present when viewed in various DNS checks, but that result is inconsistent.

Environment

Release : 16.x and earlier

Component : Enforce DetectionServerController service

Cause

The Enforce server communicates to the Cloud Service for Email Detector via the Cloud Service Gateway (the "CSG"). This connection is recycled once every 24 hours, and on re-connection to the CSG, the TXT record check of all domains configured for the Email Service is re-validated.

If the DNS record for any domain is not complete or has configuration issues, the check will fail - reverting the domain to an "invalid" state, preventing the email service from accepting messages from that domain.

Resolution

Confirm that the TXT record is consistently reported as having the DNSCode which is supplied by Symantec for the Cloud Email Detector. This code is listed in the Detector page in Enforce, and must be present in this same format (case sensitive) as listed.