SAML authentication is not working from UIM 9.0.2 release onwards
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SAML authentication is not working from UIM 9.0.2 release onwards

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Article ID: 190005

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

SAML authentication is not working from UIM 9.0.2 release onwards

Environment

Release : 9.0.2
Component : UIM - UMP LIFERAY v9.0.2

Release : 9.2.0
Component : UIM - UMP LIFERAY v9.2.0

Cause

In 9.0.2 a Liferay patch is installed
In 9.2.2 along with the Liferay patch, Tomcat is upgraded

Resolution

Assumption:
All SAML configuration related steps mentioned in the UIM documentation is already done in UMP

In 9.0.2 do the following steps:
1. Deactivate wasp probe in UMP robot
2. Delete work folder in wasp directory
3. Go to the path <UMP_installation>\probes\service\wasp\webapps\ROOT\WEB-INF\classes and edit the portal-ext.properties file in UMP robot.
4. Add the following property and save the file
    session.enable.phishing.protection=false
5. Activate wasp probe
6. Clear browser cache
7. login UMP using SSO

In 9.2.0 do the following steps:
1. Take the backup of wasp folder from UMP robot installation path. This is mandatory because new installer will overwrite some directories.
2. Re install UMP using UMP 9.2.2 installer from the UIM Hotfix Page link: https://ftp.broadcom.com/user/downloads/pub/UIM/UIM_Probe_Hotfixes/UMP9.2.2SAMLfix.zip
3. Once installation is successful, deactivate wasp in UMP robot.
4. Delete work folder in wasp directory
5. In <UMP_installation>\probes\service\wasp\lib\services delete the following three jar files:
hibernate-commons-annotations*
hibernate-core-*
hibernate-entitymanager-*
6. Delete the xerceslmpl.jar file from the directory <UMP_installation>\probes\service\wasp\webapps\ROOT\WEB-INF\lib
7. From backup location, restore portal-ext.properties file to <UMP_installation>\probes\service\wasp\webapps\ROOT\WEB-INF\classes
8. Add the following property and save the file
session.enable.phishing.protection=false

9. From backup location, Restore data folder to <UMP_installation>\probes\service\wasp\webapps\ROOT
Note: This path may vary according to the customer's configuration. Default is data folder in ROOT directory as per the SAML documentation.
10. Activate wasp probe
11. Clear browser cache
12. login UMP using SSO