CA Process Automation (PAM) doesn't start after restarting services and error "Caused by: java.sql.SQLException: Login failed for user 'sa'. Reason: The account is disabled" appers
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CA Process Automation (PAM) doesn't start after restarting services and error "Caused by: java.sql.SQLException: Login failed for user 'sa'. Reason: The account is disabled" appers

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Article ID: 189922

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager Process Automation Manager

Issue/Introduction

When starting PAM, the following error appears in the logs:

Caused by: javax.resource.ResourceException: Unable to get managed connection for OptinuityDS
 at org.jboss.resource.connectionmanager.BaseConnectionManager2.getManagedConnection(BaseConnectionManager2.java:441)
 at org.jboss.resource.connectionmanager.TxConnectionManager.getManagedConnection(TxConnectionManager.java:381)
 at org.jboss.resource.connectionmanager.BaseConnectionManager2.allocateConnection(BaseConnectionManager2.java:496)
 at org.jboss.resource.connectionmanager.BaseConnectionManager2$ConnectionManagerProxy.allocateConnection(BaseConnectionManager2.java:941)
 at org.jboss.resource.adapter.jdbc.WrapperDataSource.getConnection(WrapperDataSource.java:89)
 ... 87 more
Caused by: org.jboss.resource.JBossResourceException: Could not create connection; - nested throwable: (java.sql.SQLException: Login failed for user 'sa'. Reason: The account is disabled.)
 at org.jboss.resource.adapter.jdbc.local.LocalManagedConnectionFactory.getLocalManagedConnection(LocalManagedConnectionFactory.java:225)
 at org.jboss.resource.adapter.jdbc.local.LocalManagedConnectionFactory.createManagedConnection(LocalManagedConnectionFactory.java:195)
 at org.jboss.resource.connectionmanager.InternalManagedConnectionPool.createConnectionEventListener(InternalManagedConnectionPool.java:633)
 at org.jboss.resource.connectionmanager.InternalManagedConnectionPool.getConnection(InternalManagedConnectionPool.java:267)
 at org.jboss.resource.connectionmanager.JBossManagedConnectionPool$BasePool.getConnection(JBossManagedConnectionPool.java:679)
 at org.jboss.resource.connectionmanager.BaseConnectionManager2.getManagedConnection(BaseConnectionManager2.java:404)
 ... 91 more
Caused by: java.sql.SQLException: Login failed for user 'sa'. Reason: The account is disabled.
 at net.sourceforge.jtds.jdbc.SQLDiagnostic.addDiagnostic(SQLDiagnostic.java:372)
 at net.sourceforge.jtds.jdbc.TdsCore.tdsErrorToken(TdsCore.java:2988)
 at net.sourceforge.jtds.jdbc.TdsCore.nextToken(TdsCore.java:2421)
 at net.sourceforge.jtds.jdbc.TdsCore.login(TdsCore.java:632)
 at net.sourceforge.jtds.jdbc.JtdsConnection.<init>(JtdsConnection.java:371)
 at net.sourceforge.jtds.jdbc.Driver.connect(Driver.java:184)

Environment

Release : 4.2 and later

Component : Process Automation

Cause

sa acount has been disabled in SQL Server Instance

Resolution

1. Log into SQL Server instance with the problem using SQL Server Management Studio using Windows Authentication or an Administrator account:


2. Expand Security folder > Right-Click on sa account > Click on Properties

3. Go to Status page > Set Login to "Enabled" > Click OK.




4. Re-try the installation.

Additional Information

https://sudeeptaganguly.wordpress.com/2010/04/20/how-to-enable-sa-account-in-sql-server/
https://dataginger.com/2013/08/20/sql-server-why-is-the-sa-login-account-disabled-how-to-enable-sa-login-account/