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Service Desk maileater is failing and the inbox of the mailbox get stuck

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Article ID: 189907

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Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

Service Desk mail eater is not processing certain emails the mailbox get stuck and it cannot advance any further, blocking all the rest of incoming emails, removing the email and restarting the process is the only option to make the maileater available again.

The log will record a message like the one bellow:

"Email size 3287296 bytes is greater than the allowed limit of 500KB bytes. Email cannot be processed."

Environment

Release : 17.X

Component : SERVICE DESK MANAGER

Cause

The issue was caused by the size of the email content which was above 500Kb, the size limit is hardcoded, this is independent  of the file attachments which are treated separately.

Resolution

To prevent this issue the suggestion is to set  that the entire email is treated as an attachment.

1. Log to Service Desk with an administrator account
2. Go to admnistration tab and then to mail select the mailbox.
3. Set the mailbox to attach the entire email to YES.
4. Restart the SD service to ensure that the maileater use the new setup.