search cancel

OPMS Upgrade Failure

book

Article ID: 189863

calendar_today

Updated On:

Products

CA App Synthetic Monitor DX Application Performance Management

Issue/Introduction

I tried upgrading an OPMS from 10.0.15 to 10.4.0 last night. The upgrade failed and the unit is now non-functional.

The following messages appeared:

Installation Failed
-------------------
Could not install Puppet 3 package.

 

 

Environment

Release : 10.4

Component : CA APP SYNTHETIC MONITOR (WATCHMOUSE)

Cause

ASM repo set to disabled.

Resolution

The problem is that we do add the ASM repo for the installation and remove it afterwards (when installation is successfully completed). So, I believe that it must have been disabled in some way after some failed installation, however the installer will not disable the ASM repo in any way.

To circumvent this problem:

1) Enable asm.repo and try to install the failed package (to verify the repo is available and not blocked).

2) Try to remove the file and restart the installation

3) If the previous step fails and installation stops in the very same place with this repo disabled again, Try manually adding the asm.repo named differently, i.e. copy asm.repo to asm2.repo, enable it and retry. Do not forget to remove the repo file after the successful installation.