search cancel

Views for metrics started showing Invalid Data message in Performance Management.

book

Article ID: 189691

calendar_today

Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

Views against metrics that used to work are now returning messages about Invalid Data. This is seen in the View where the chart or graph should be.

Cause

The relationship between the Metric Family and it's Monitoring Profile was broken. The Metric Family was no longer part of the related Monitoring Profile.

As a result this broke the relationship between the devices and the Metric Family by severing the relationship that was present between Device<->Collection<->Monitoring Profile<->Metric Family<->Vendor Certification.

The primary clue here is observing the items for those Metric Families (Polled Metric Families tab for device in Monitored Devices Inventory) with a Filtered and Not Polled state.

Environment

Release : 19.1

Component : IM Reporting / Admin / Configuration

Resolution

Add the related Metric Family back to the Monitoring Profile involved.

Within a few minutes the items should go back to Active and Polled.

Within 15-20 minutes, after 2-4 poll cycles have passed we should begin to see polled data return again.