SV-Connection issues when pointing VSE services to Registry server:ERROR com.ca.sv.invoke.controller.v2.VseServerController - JMS Messaging problem
search cancel

SV-Connection issues when pointing VSE services to Registry server:ERROR com.ca.sv.invoke.controller.v2.VseServerController - JMS Messaging problem

book

Article ID: 189681

calendar_today

Updated On:

Products

CA Cloud Test Mobile CA Application Test

Issue/Introduction

We're seeing issues when trying to connect VSE services to a new Registry server.

These issues seem to block any VSE services from connecting to Registry server.

Registry logs:

Caused by: com.itko.jms.JMSException: Could not connect to broker URL: tcp://nc2-068a:2013?wireFormat.maxInactivityDuration=0. Reason: java.net.ConnectException: Connection timed out: connect
 at com.itko.activemq.util.JMSExceptionSupport.create(JMSExceptionSupport.java:35)

And

2020-04-23 23:15:41,418Z (18:15) [qtp2046211968-2382] ERROR com.ca.sv.invoke.controller.v2.VseServerController - JMS Messaging problem with ServerRequestHandler for tcp://nc2-068a:2013/WIBSV-dev-f-RnD-S22-fbepr-4927 Could not connect to broker URL: tcp://nc2-068a:2013?wireFormat.maxInactivityDuration=0. Reason: java.net.ConnectException: Connection timed out: connect; nested exception is:
 com.itko.jms.JMSException: Could not connect to broker URL: tcp://nc2-068a:2013?wireFormat.maxInactivityDuration=0. Reason: java.net.ConnectException: Connection timed out: connect
java.rmi.RemoteException: JMS Messaging problem with ServerRequestHandler for tcp://nc2-068.com:2013/WIBSV-dev-f-RnD-S22-fbepr-4927 Could not connect to broker URL: tcp://nc2-068a:2013?wireFormat.maxInactivityDuration=0. Reason: java.net.ConnectException: Connection timed out: connect; nested exception is:
 com.itko.jms.JMSException: Could not connect to broker URL: tcp://nc2-068:2013?wireFormat.maxInactivityDuration=0. Reason: java.net.ConnectException: Connection timed out: connect
 at com.itko.lisa.net.Transporter.init(Transporter.java:412)

 

Environment

Release : 10.4

Component : CA Service Virtualization

Cause

Firewal not open both ways for Registry to VSE server  and vice versa. 

We tried to ping from both machines

1. Registry machine on 3073 -> VSE ( this failed)
2. VSE server to the Registry machine ( This works)

Resolution



Work with your network team for Firewall configuration on both servers. We need to Telnet or Ping both ways